Veras rhino 7

hi im new to veras. just want to know that is the intergration of veras with revit better in some way. Because i have tried to do do few interior renders but veras completely changes the shape of my furniture which i dont want. Is it normal for this to happen ?

Welcome to the forum @yumyum,

The AI image generation wouldn’t treat the images any differently based on whether they are coming from a Revit or Rhino model. However, Revit could be supplying images that are easier for the AI model to interpret-- and perhaps Rhino is not. For example, in one software you could have view settings enabled that result in more defined lines in your model which make it easier for the AI to interpret the geometry.

Take a look at these two posts which take you through the steps of adjusting your view settings to be ideal for AI rendering with Revit and Rhino, respectively:

This should make a positive impact for you if you haven’t done these steps already. One additional tidbit I can offer is that the “geometry override” slider seems to have slightly different effects whether you’re using the Version 4 vs. Version 5 rendering engine… So if you’re not achieving your desired results, it’s worth experimenting with considerably different values of “geometry override” with each engine and seeing what works best. That render engine can be changed in your Veras settings.

Let me know if these recommendations help or not!


Oh okay. Thanks for just a detailed explanation. Can we not do any setting in rhino to make it easy for ai to interpret the model easily or maybe it come in the upcoming updates ? Or is this just a software problem.

Hmm. Well I don’t know if there is an equivalent to Revit’s “show edges” setting in Rhino… If you’ve tried everything suggested and are still getting issues with the geometry, would you mind sharing your Rhino 7 substrate image, as well as the result you’re getting (also showing the render settings you’re using)? Usually I don’t get issues with the geometry like you’re describing – or if I do, it’s just a one-off bad rendering.