SketchUp to Revit

Moving over sketch up models to Revit stopped working. I tried deleting the cache, used a small model, etc.

Revit to SketchUp works.

@Tecture Thanks for posting! What happens when you try to move a model from SketchUp to Revit? Do you have a sample SketchUp model you can share with us? If so, I can try to reproduce the issue on my end and see if I can get it working for you!

It just doesn’t arrive at Revit when sending to Revit. It’s any model. Starting a new file with just a cube won’t move over either.

1 Like

Ok @Tecture thanks for the additional info, that certainly is odd. I’ll play around and see if I can’t figure out a few reasons this could be happening, and report back!

Any updates on this?

I put together a test SketchUp file with the Helix mapping:
2024-07-10 Test Model.skp (82.1 KB)
helix mappings.hlx (2.2 KB)

Testing

In SketchUp

  1. Open the SketchUp model
  2. Open Helix
  3. Import the mapping
  4. Click Send To Revit

In Revit

  1. Create a new project (used Imperial settings)
  2. Go to a 3d view (to see the model once loaded)
  3. Go to the EvolveLAB tab and click the Load Model button under the Helix panel
  4. Click the Status Report to see if any elements had errors

Please let us know if you have any issues with testing using the sample files. If you have errors in the status report, please post a screenshot.

1 Like

Hi,

that worked for the geometry that was in the model. If I build a simple cube and try to move it over as a Mesh(DXF)/Generic Model, Revit doesn’t import it. No warnings or anything in the status report.

I updated the model to include a generic object:

2024-07-11 Test Model.skp (90.0 KB)
helix mappings.hlx (2.4 KB)

I opened the model you sent and tried to send it over and now neither the cube or the building is coming over to Revit.

I managed to move the house over, but the generic model of the cube you have added is still not included.

That is really odd - perhaps the Revit Family Template files were not copied over. You can try to reinstall Helix to see if that is the fix.

Do you get an error with the in the reports? If you don’t get an error, you should be able to click on the element ID. It could be that the object is really far away for some odd reason. If you do get an error, please post a screenshot.