From Sketchup 2023 to Revit 2024

I’m trying to convert a simple 2023 version SketchUp model into a Revit 2024 model with Helix. Unfortunately, despite following the indicated procedure, the outcome is negative. That is, the export yields no result. The reverse process, however, works. Does anyone know what might be causing the problem?

@cervoni - welcome to the forum!

Can you share a bit more about your setup?
What mappings did you use?
Can you check the Status Report in Revit Helix? (see example below)

Here’s a comprehensive example for this process: Convert SketchUp Model to Native Revit BIM

1 Like

I have done a simple Sketchup file with an object that should become a wall in Revit.
Find attached the sceenshots and the skp itself.
The result in Revit is any effect.
The most probable thing is that I am missing some step but I don’t understand what.

Revit side element sync status report results emty.

It seems that sinc doesn’t happen

but I don’t understand why.

I do sinc but it has no effect.


The layer must be applied to the SketchUp face, not the group. Helix currently doesn’t detect the layer when it’s applied to the group.

EDIT: it seems like you properly set the layer (tag) to the SketchUp face

After clicking the Send To Revit button, do you get the Sync Completed message?

If YES, then

  • can you go to this directory C:\ProgramData\EvolveLAB\Helix
  • check if there is a file called model.hlx
  • if the file exists, can you please upload that file here?

“I have carried out the procedure. Although the export message returned a positive response (green checkmark), from the date of the last modification, I notice that the model file has not been updated (I attach it along with the mapping file).”

mapping.hlx (1.1 KB)
model.hlx (63 Bytes)

I see. Thank you for the attached files.

Seems like the model.hlx is actually empty:

	"face_elements": [],
	"component_elements": [],
	"line_elements": []

Can you try to delete both hlx files, restart SketchUp, and try the mapping and exporting process again?

It could be that with one of our latest updates, the Helix Hub has reduced access that limits the ability to interact with files generated from the previous versions.

Dear Ben,
I did what you advised me to do and it worked.
Very well.
Happy Easter.

1 Like

I’m glad it worked! Happy Easter!!

1 Like