Render failed due to the following error: Error: Network Error

Today, when I attempted to render images on Veras web, I encountered an error message

@mohammed3333 - I’m sorry to hear that it’s not connecting!

I have questions:

  • Did Veras work before today?
  • From what country are you trying to access Veras?
  • Are you using a VPN?

*yes it always works but in large image resolutions like 3840x2160 this error came up
*from Jordan
*no I am not using VPN

I see - that’s very useful to know. So it seems like the larger data package somehow can get interrupted. We’ll look into this further, and update this thread with the status.


Dear Veras colleagues,

I`m not able to get rendering by Veras. Tried several times today, but also few weeks back.
With an Error

Error: Render Failed
Render failed due to the following error:
Error: (“(‘Connection broken: IncompleteRead(4069 bytes read, 34976 more expected)’, IncompleteRead(4069 bytes read, 34976 more expected)), line 737”, 500)

Connecting from Slovakia, but trough company VPN (Germany) If you need more information, pls let me know.

Martin (ALLPLAN)

@mmikus - good to see you here on the forums!

I’m sorry to hear that you are getting theses errors. Some questions:

  • Are you getting this error for every render, or do some of the renders work? (like lower rez renders)
  • Is this through the custom implementation of the SDK, or using the standalone web app ? (

Hi Ben,

nice to be here and gave some feedback.
Few more information:
Tried yesterday (08:00 PM CET) several times and all rendering requests failed all the time, used low res calc. (original image 1K, output 768px)

  • via VPN, using Veras via standalone Veras web-app

Tried today (09:00AM CET) with same settings and environment (VPN) - Rendering successful for both Veras standalone web-app & in Allplan (via WebViewer)
so only difference I see is time - maybe server overload??

Render outputs are amazing. Surely there are in many cases lot of artefacts in the image. But in there I need to gain more experience if this can be prevented by prompts and/or settings.


Really neat observation! We are working on backend updates that will address the peak time stability - this should be resolved soon.

Also, thank you for the complements!