Elevation View Creation not Working Properly when Room has flooring (carpet) modelled

Issue when a floor has been used to model a flooring type (carpet) on top of the actual floor (conc. slab) - the elevation view creator identifies the carpet as the top extent of the view and you end up with elevations that look like this:

If you untick room bounding for the carpet, nothing changes, it still uses the carpet as a basis for bounding the top extent of the view. :x:

If you adjust the order that the items are modelled in i.e. model the slab, then the carpet, then the room volume, it doesn’t work properly :x:

If you delete the carpet, the view will be created with the ceiling as the top extent. :white_check_mark:

If you put the carpet on a separate workset and turn that off globally, the view will also be created correctly. :white_check_mark:

If the top of the carpet is 12.7mm or less from the base level of the room volume, view will be created correctly. :white_check_mark:

Hi @Tom_Sheridan,

Thank you very much for reporting this bug, we just added it to the bug log and we will fix it in the next release.

On a side note, another temporary fix to this will be to change the following setting:


1 Like

Thanks for the response, and for adding this to the bug list.

Your workaround would work in theory, but the Room Height setting doesn’t seem to take into account that the ceiling is a room bounding element. i.e. If the room volume is modelled @ 2.9m tall, and your room bounding ceiling is at 2.7m tall, the tool reads the actual height of the room volume, not the bound height. I assume it’s reading the Limit Offset parameter of the room and applies that - this is an issue I also encountered when I was trying to make a very similar tool to Glyph for my team using Dynamo.


1 Like

That’s correct, if “room height” is selected it will read the limit offset parameter.

I will respond to this post once we fix the bug you found.

Thank you again for reporting this bug!