Download free trial not able to install

I want to install Veras as a free trial. But when I open the zip-file it is not possible. perhaps only for windows?
I already tried another way. Download the el_veras_rbz file what Ben mentioned in the forum but then I only get a text file not a setup file or something similar.
Please help.

Thanks in advance.

Kind regards,


1 Like

Problem solved. Allready used 22 out of 30 renders :sweat_smile: :smiling_face_with_tear:


I’m glad it’s resolved. Did you have to rename the txt extension? What was the solution?

1 Like

I renamed the file and then followed the steps you mentioned in a topic.

1 Like


Here’s a reference link to the post with this .txt rename issues: Download with txt Extension

I can’t access the page. The free trial installation link is not working. Can you help me with it.

1 Like

Hello Mr. Ben,

I also have the similar problem. When I click the install bottom the new window does not open. I would be happy if you can help me.

Kind regards,

@simay & @TilbeK - can you try this link instead:

You will have to unzip the file and run the msi file.

Hi Ben,

I have downloaded the free trial but it seems only a Rhino extension was included and no Revit. Is this normal? And where can I download the Revit extension?


That’s odd. What version of Revit do you have installed?

Hi Ben,

Thanks for your response. It seems the first download only had a Rhino extension.

I have now solved the problem with a new downlead link, from this chat chain.

Thanks anyway

1 Like

Thanks for the update. We’ll fix the main link asap!