Can't save images in release 1.5

Although the images are being saved automatically successfully in version 1.5 so far, I can’t save them myself, which I have been able to do with other versions. Sometimes I like to save them so I can add a note to a result, or sometimes the automatic save doesn’t work (in other versions, occasionally); or I can at least always right click the image and do a “save image as.” But in 1.5 no other options are available, I can’t hand save the image (see my attachment) and right clicking doesn’t work, nothing happens.

When I try to save the file, in the area where I would specify the type of file, there is verbiage and no way to specify a file type.


1 Like

Hi @SketchVeraslady,

Thank you for bringing this to our attention! You’re right, I was able to reproduce the same bug. However, it seems to only be a problem for me when my prompts are very long, since the prompts are used to build the default file name; and the long file name seems to be challenging the ‘Save File’ dialog window we’re using, or the operating system, itself. This shouldn’t be a problem for autosaving because we already truncate the prompt when it’s being used for the default file name. However, we seem to have overlooked this for the manual saving procedure, and will need to truncate the file name there too.

Our offices are technically closed for this week, so I am putting in an order for this to be fixed for our next release. If you make any other observations about this issue, please let us know. Thanks again for sharing!



Thank you, that’s an interesting explanation. I’m also having a problem making copies with the web app. It doesn’t return a png or jpeg, instead I get a blank looking copy that I then have to choose to open in photoshop, and I have do that with every image. It gets confusing and I keep losing track of the higher resolution copies, end up with only the lower resolution image I save by right clicking on image. Thanks.

Hey @SketchVeraslady ,

Sorry, I’m a little confused when you refer to “making copies with the web app.” Are you trying to copy-paste the resulting renders to another app?

This is a list of results that Veras web app saved. I don’t know what they are, they are not jpegs or pngs. I have to open them in another app. I use photoshop. I just tried it with a prompt with 600 words and a prompt with 200 words and it was the same for both, got the blank looking file. I thought it might be happening because my prompts were too long. Thanks.

blank files I have to open in another app like photoshop

1 Like

@SketchVeraslady ,

Thanks for the screenshots and clarification! OK, so that is quite odd, indeed. When did this start happening? Has it been happening ever since you started attempting to use the “Save Selected Image As…” button?

I’m thinking it could be a browser incompatibility issue. I’m not suggesting you need to use another browser; I think we can fix this. Here is a url for a test-deployment of Veras where the saving is done in a slightly different way:

Would you mind trying this version and seeing if this fixes the saving/downloading issue of the image?

1 Like

Greg, This started happening about 3 weeks ago; but I have rarely used the app until about 3 weeks ago. I didn’t notice too much difference between the regular app and the test deployment version. I did try another browser. It switched to intermittent after I wrote. And then tonight it was working fine every time (the app).

But now I can’t save any images at all with 1.5. Images were being saved successfully automatically for quite a while today then it stopped working, screen said there was an error and the automatic save no longer worked. In the past if that happened, I had the option to save it another way. Now I can’t save images on 1.5 at all. I also tried reloading the program.


Maybe it will work again at another time. That has happened before with other versions. It’s just in this case I have no other way to save.

Release 1.5 has not worked for two days; can’t save images.

We’re looking into this issue, and we’ll post updates here when available. Thank you for your patience.