Auto-Dimension by line

Hi there, how come sometimes when the line crosses a wall, it will correctly dimension the finish face on the interior and exterior but sometimes its dbl dimensions one side of the wall and creates a 0" dimension even if i have a filter to only dim larger than 1 1/2" ?? Also how do I get the offset to work? doesnt matter what number i place in there is doesnt change, revit natively allows you to pull the dims away once completed. How does Glyph address this? Thanks all, love the tool really want my firm to embrace it

Hi @jigalvan,

Once the dimension is committed, you should be able to move the dimension freely.
Can you please post a photo of your current dimension settings? Also, are they duplicated walls on top of each other?


Thanks for the quick reply, @Miguel l! Yeah that works fine but it’s an extra clean up step, curious is a pull away feature will be a part of the tool. What is the purpose of the offset value? At first glance, i read that as a way to address this since you don’t always want the dimension string to live where you draw the line for dimensions in the tool but no matter what value I put in there (1-100), nothing is different. No duplicated wall in the model, however we do have wall base sweeps built into the family, perhaps that may be something? Attached image is the settings. Wall dimension option is Interior Wall Dimensions. The Wall references is set to Finish Face Exterior and Finish Face Interior. Category is Walls / Curtain walls with a filter of only above 1 1 /2" so not sure how its getting a 0" dimension.

Thanks for sending these settings, I just tested on my end, and it looks like the “offset setting” was disabled for the “by line” feature. We will add it back to the next release.

I will do further testing on my end but it is probably your wall sweeps. If I find anything, I will include it in the next release.


1 Like