Cannot login through the SketchUp 2021.0.339 Extension with v1.7+

I enter my credentials and press login , seems to be loading for a second and then it just deletes my information with no feedback .Relevant screenshots below.
Additional information: Sketchup 2021 , country of operation is Greece. Veras


Second screenshot here as i am not authorized to post both as a new member

1 Like

@xaris.molakidis - welcome to the forum.

Thank you for posting the issue here. Would it be possible to test Veras using SketchUp 2022 or 2023?

Can you access the standalone version of Veras?
Does login to the licensing portal work for you? EvolveLAB | Customer Portal

Thank you for your quick response.

Can you access the standalone version of Veras?

: Yes i can this is how i have been using it so far . Even though i assume it would be more convenient through the extension.

Does login to the licensing portal work for you? EvolveLAB | Customer Portal

: Also yes.

1 Like

Thank you for more testing!

The SketchUp viewer is also a web browser, so it must be a difference in the webrowser version. Do you have a newer version of SketchUp to test with (2022 or 2023)? It might be that the browser version is the issue, and this test could possibly confirm that speculation.

I ran another test using VPN to Greece in SketchUp 2021, and everything worked fine:

I did notice that the login window format was collapsed for you, so you might be using an older version of SketchUp 2021. Perhaps you can update to the latest SketchUp 2021:

I’m using version 21.1.332 64-bit

Here’s how you can check your version:

1 Like

I updated the title and category to better reflect this problem.


I have the same problem. Veras was working fine for months before the last update. Upgrading to newer version of sketchup is not an option. Is there another solution?

Thanks in advance

@dbibas - sorry to hear that. We are looking into this, and have some additional questions for now:

  • What version of SketchUp are you using?
  • Can you test Veras on multiple versions?
  • If testing with multiple versions, does the login work on some versions?

Per your other post, it seems like the web app is working correctly, which is good to know.

To access the previous Veras version:
Windows: EvolveLAB_Veras_v1.6.4.5.msi
Mac (SketchUp): EvolveLAB_Veras_v1.6.4.5.rbz

1 Like

Hi ben, i was unable to sign in to veras. can you help me, please ?

@pertek - welcome to the forum!

I moved your post here, as it’s the more relevant thread.

Some questions:

  • From what country are you trying to access Veras?
  • Are you using a VPN?

Here are some things to try. Can you:

I’m using sketchup pro 2021 Version 21.0.339 64 bit.

Thanks a lot, Veras v1.6.4.5 works just fine. Is there going to be a fix for this problem with the next version? The problem persists with the latest Veras version.

@dbibas ,

It may require a separate, bespoke solution to be maintained just for this separate minor version of SketchUp. It’s even possible that it’s not just an incompatibility, but a bug in that browser version that was fixed with a later patch. I’ll see if I can find any release notes for that chromium version that could elucidate the matter, and whether it’s possible to address. I’ll discuss with @Ben --and connect with our developer who works on licensing to see if they have some other idea, as well.


As @Greg said, we looked into this and it seems that it may be a issue with SketchUp 2021 Version 21.0.339.

The version of the Chromium browser that ships with that particular version of SketchUp 2021 may have a bug that prevents out login code from working correctly.

If possible, upgrading to the latest version of SketchUp should solve the issue. If you need to stay with SketchUp 2021, you can simply update to the latest version of 2021, which as of today, 7/2/2024, is Version 21.1.332.

I found this unofficial link where you can download older SketchUp versions, and it currently includes version 21.1.332:

That said, we are currently looking to see if we can figure out a workaround. If we do, we’ll release an updated installer and post about it here!

Thanks everyone for letting us know about this issue, hopefully we can get it resolved soon!

1 Like